You are here

Overdrive eBooks & Audiobooks

Overdrive: Issues with older Apple devices or browsers

Recent changes by Overdrive and Libby have impacted compatibility with older versions of Apple's mobile and desktop operating systems. Those who use older Apple devices (Mac computers running lower than macOS 10.12.1 and iPhones/iPads running iOS 9) may have trouble using the OverDrive desktop or mobile apps, while Libby is no longer supported on iPhones and iPads running iOS 9.

Homepage of Overdrive

eBooks and downloadable audiobooks. Compatible with most devices.